The PT Boat Forum
http://www.ptboatforum.com/cgi-bin/MB2/netboard.cgi


Forum Category: PT Boats of WWII
http://www.ptboatforum.com/cgi-bin/MB2/netboard.cgi?cid=101&fct=showf


Forum Name: PT Boats - General
http://www.ptboatforum.com/cgi-bin/MB2/netboard.cgi?fct=gotoforum&cid=101&fid=102


Topic: Major error in 80' page
http://www.ptboatforum.com/cgi-bin/MB2/netboardr.cgi?cid=101&fid=102&tid=218



The 80' data page (http://www.ptboats.org/20-01-05-ptboat-001.html) contains a major error. It states that 30 boats went to Canada and one to Russia. Unless someone has come up with a previously unseen official document, no 80' ELCOs ever served in the RCN and a large number of 80' boats went to the Soviets, including most of the surviving boats of RON29, 34, & 35.

Perhaps someone should rethink the entry on that page... :-}

Al Ross



Posted By: alross2 | Posted on: Jan 11, 2007 - 2:36pm
Total Posts: 994 | Joined: Oct 30, 2006 - 8:19pm



Dr. Ross,

I've alerted PTBI to the error.

Garth

You've got a question, I've got an answer.

Posted By: TGarth Connelly | Posted on: Jan 12, 2007 - 6:59am
Total Posts: | Joined: Unregistered



FYI ALL ............

The error was conveyed to the Webmaster today by PTBI HQ.

Garth

You've got a question, I've got an answer.

Posted By: TGarth Connelly | Posted on: Jan 16, 2007 - 11:33am
Total Posts: | Joined: Unregistered



Please excuse the error, I had created that page back in 1997 and not sure what I was thinking when I but Canada in the mix - must have been one of those unexplained late-night-typos.

[b]The information has been amended to:[/b]

296 Elco 80' PT Boats used by U.S. Navy

30 Elco 80' PT Boats, PT's 731-760 were sent to USSR - all but PT-731 was sent in "knocked down" condition for assembly in Russia.**

** Information per At Close Quarters page 484.

Website Reference: [url]http://www.ptboats.org/20-01-05-ptboat-005.html[/url]

Dick Washichek,
Webmaster



Posted By: Dick | Posted on: Jan 16, 2007 - 6:06pm
Total Posts: 1468 | Joined: Aug 27, 2006 - 6:36pm