PT Boat Forum


Moderated by: Dick, Jeff D

The PT Boat Forum ª ª  PT Boats - General

´ Prev Page | Next Page ª | Page 92 of 252

Totals: Topics 5033 Replies 36069 Messages 41102

    Topic Author

Views

Replies

Last Post
Open Topic
 
Scaling Scanned Drawings Member Jeff D

2744

3

Jul 17, 2013 - 6:52am
Open Topic
 
Reuse of PT Boat Conversion Kit Member Dave Vervalin

787

3

Jul 17, 2013 - 6:52am
Open Topic
 
PT Conversion kit reuse Member Dave Vervalin

770

0

Jul 16, 2013 - 10:07am
Open Topic
 
MKVSOC soon on display Member TED WALTHER

992

2

Jul 16, 2013 - 10:07am
Open Topic
 
Need info on armor removed from PT-105 and Ron 5 boats Member David Waples

2531

2

Jul 14, 2013 - 10:28am
Hot Topic
 
Another 1/35 PT-109 Build-Almost from the Box! Member Phillip Gore

10916

39

Jul 14, 2013 - 10:28am
Open Topic
New Article, Member Don Millman

2649

0

Jul 12, 2013 - 1:26pm
Open Topic
 
New RON 19 PHOTOS - Set 2 of 2 Member Frank J Andruss Sr

4660

7

Jul 12, 2013 - 1:26pm
Open Topic
 
stories Member earl

2550

1

Jul 12, 2013 - 1:16pm
Open Topic
 
Construction manual for PT 109 Member victorkchun

2729

9

Jul 12, 2013 - 1:16pm
Open Topic
 
Italeri PT Boat Conversion Set kit - A closer look Member David Waples

8770

10

Jul 11, 2013 - 5:45pm
Open Topic
 
PT Boat personnel's family housing in Newport, RI 1943-1945 Member Joseph CutshallKing

885

6

Jul 11, 2013 - 5:45pm
Open Topic
 
Dec. 1943 to Nov. 1944 Hurricane's ? Member MN Gal

2516

4

Jul 11, 2013 - 5:42pm
Hot Topic
 
PT 305 RESTORATION PICS Member RANDY SMITH

7600

44

Jul 11, 2013 - 5:42pm
Open Topic
 
Navigation horn correction for PT-157 model Member TheBridge

1540

10

Jul 11, 2013 - 4:20am
Open Topic
 
HAPPY FATHERS DAY!!!! Member TED WALTHER

2576

3

Jul 11, 2013 - 4:20am
Hot Topic
 
Italeri PT 109 Build 2, by Stuart Hurley Member Jeff D

2606

31

Jul 10, 2013 - 8:40pm
Open Topic
 
LATE SQUADRONS BOAT NUMBERS Member TED WALTHER

4131

5

Jul 10, 2013 - 8:40pm
Open Topic
 
Heartfelt thanks Member PeterTareBuilder2

788

2

Jul 10, 2013 - 6:24pm
Open Topic
 
Elco 80' Mast Error Member Jeff D

2775

4

Jul 10, 2013 - 6:24pm

´ Prev Page | Next Page ª

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 [92] 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252

 

Forum Legend

Open Topic

Hot Topic / Topic with more than 15 replies

Locked Topic

Sticky Topic

Post From The Forum Moderator

Post From a Member

Posted Within The Last 24 Hours

Voting Poll

Who May Post? Registered Users

Last Visitors: PT297 | Drew Cook | Rock55 | Scott C | PRJM3 | Lew Zee | Jeff H | 29navy | Michael L | Jeff D | Frank J Andruss Sr | scott 4243 | Andy Small | Old LeadBottom